Forum d'entraide TOWeb - Le logiciel de création de site web responsive
Retour au site lauyan.com

Bienvenue, Invité. Veuillez vous connecter ou vous inscrire.
Avez-vous perdu votre courriel d'activation?
Identifiez-vous Inscrivez-vous Accueil du forum Aide sur le forum

Lancement de pagexl.com pour la création gratuite et facile de sites "one page" (page unique)

IMPORTANT: Avant de poster un message sur le forum n'oubliez pas :
1. d'effectuer une recherche sur le forum ainsi que dans l'aide en ligne TOWeb
2. de consulter les tutoriels vidéo sur YouTube et les dernières informations du blog de TOWeb
3. de consulter les tutoriels de Frangin62
+  Forum TOWeb
|-+  TOWeb
| |-+  Discussions générales sur TOWeb
| | |-+  [RESOLU] Mailinglist fonctionne pas
« sujet précédent | | sujet suivant »
Pages: [1] Bas de page Imprimer
Auteur Fil de discussion: [RESOLU] Mailinglist fonctionne pas  (Lu 168 fois)
prapilk
Newbie
*

Nombre de "j'aime" : 0
Messages: 9


« le: 31 Mars 2019 à 15h28 »

Bonjour à tous,

Je suis chez ATSPACE en PHP 7.3.3, sur toweb je sais faire des formulaires mais le mailinglist bug.

J'ai cette erreur:

Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /srv/disk1/***********************************/mailinglist.php on line 11

Warning: Cannot modify header information - headers already sent by (output started at /srv/disk1/*********************************************/mailinglist.php:11) in /srv/disk1/*****************************************/mailinglist/mailinglist.php on line 45

En espérant que vous pourrez m'aider.
« Dernière édition: 01 Avril 2019 à 21h42 par prapilk » Journalisée
prapilk
Newbie
*

Nombre de "j'aime" : 0
Messages: 9


« Répondre #1 le: 31 Mars 2019 à 15h35 »

Le script dans mailinglist.php

Supprimé car trop long et pas utile
« Dernière édition: 31 Mars 2019 à 22h26 par prapilk » Journalisée
frangin62
Hero Member
*****

Nombre de "j'aime" : 96
Messages: 2014



WWW
« Répondre #2 le: 31 Mars 2019 à 20h37 »

Bonsoir,

La réponse se trouve sur le site de PHP.net, il semble qu'on va commencer à avoir des soucis avec les versions trop évoluées de PHP.

.

Deux solutions :
 1 : remonter le problème à Lauyan
 2 : voir chez ton hébergeur s'il ne propose pas une version de PHP antérieure à 7.2.0

Cdlt
frangin62
« Dernière édition: 31 Mars 2019 à 23h21 par frangin62 » Journalisée

prapilk
Newbie
*

Nombre de "j'aime" : 0
Messages: 9


« Répondre #3 le: 31 Mars 2019 à 22h28 »

Merci Frangin62,

je suis repassé à la 7.1.27 qui est la toute dernière en 7.1 supporté par mon hébergeur.

Ca fonctionne un grand merci.

Journalisée
frangin62
Hero Member
*****

Nombre de "j'aime" : 96
Messages: 2014



WWW
« Répondre #4 le: 01 Avril 2019 à 09h02 »

Bonjour,
Si c'est bon pour toi, tu peux mettre Résolu sur ton premier post. Par contre le titre n'est pas vraiment explicite car on supposerait que tout va bien vu que tu mets un OK, j'aurai plutôt mis " Problème de mailinglist ".

Par contre il va quand même falloir que Lauyan pense à cette évolution négative de la part de PHP.

Cdlt
frangin62
Journalisée

prapilk
Newbie
*

Nombre de "j'aime" : 0
Messages: 9


« Répondre #5 le: 01 Avril 2019 à 21h44 »

Visiblement je vais encore attendre avant de mettre résolu.

J'ai bien la confirmation de mon inscription à la mailing list mais je reçois aucun mail....

Je vais essayer encore d'autre version de PHP pour voir  Triste
Journalisée
frangin62
Hero Member
*****

Nombre de "j'aime" : 96
Messages: 2014



WWW
« Répondre #6 le: 02 Avril 2019 à 00h01 »

Bonsoir,
J'ai testé les deux méthodes d'envoi vers deux adresses, free et hotmail, cette fois j'ai bien reçu les 4 mails.
Pour info,  je suis chez free, le version de php  est 5.6.34, mon logiciel de messagerie est Thunderbird.
J'ai par contre souvent des problèmes de réception, aussi bien formulaire de contact, bon de commande ou mailinglist et je ne sais pas exactement pourquoi. Mais le soucis ne provient pas de TOWeb vu qu'on l'utilise toujours de la même façon. C'est plus lié au fournisseur de messagerie, qui est le plus souvent le FAI.
Il y a déjà beaucoup de posts concernant ce fichu problème de réception.
Cdlt
frangin62
Journalisée

prapilk
Newbie
*

Nombre de "j'aime" : 0
Messages: 9


« Répondre #7 le: 02 Avril 2019 à 15h18 »

Citation
    Bonjour,
    Les formulaires fonctionnent bien et mon test PHP est ok.
    En PHP 7.1.27 (la seul qui n'est pas encore obsolète en 7.1) abonnement à la mailing list accepté mais aucun mail envoyé.
    Par contre, en 7.2 et 7.3 les scripts TOWEB ne sont pas à jour et le mailing list bug !
    En espérant que vous mettrez à jour toweb pour le 7.3.3
    PS: un stock en e-commerce avec un comptage du stock visible pour les acheteurs me fera acheter votre version e-commerce.

Reçu de Toweb ça:

Citation
Bonjour, merci de nous avoir signalé ce probleme, cela sera effectivement corrigé lors de la prochaine mise à jour de TOWeb. Merci de nous l'avoir signalé.

L'équipe TOWeb

Plus qu'à espérer que ça sorte demain  Souriant
Journalisée
frangin62
Hero Member
*****

Nombre de "j'aime" : 96
Messages: 2014



WWW
« Répondre #8 le: 02 Avril 2019 à 16h07 »

Bonjour,
J'ai également reçu cela

Citation
Bonjour, merci de nous avoir signalé ce probleme sur lequel nous allons nous pencher
L'équipe TOWeb
----- Original Message -----
From: <XXXXXXXXXXXXXXXXXX>
To: <support@lauyan.com>
Sent: 2019.04.01 09:10
> Bonjour,
> Je voudrai attirer votre attention sur un problème qu'à rencontré un Towébien.
> Suite à l'évolution de PHP chez son hébergeur, la 7.3.3, les fonctions de mailing ne fonctionne plus.
> Vous pouvez voir le fil ici
> http://www.lauyan.com/forum-fr/index.php?topic=9267.0
> Cordialement
> frangin62

TOWeb ne sera pas le seul concerné, je pense qu'il y a beaucoup de scripts dans le monde qui utilisent cette fonction each() et peut-être d'autres.
C'est le problème avec des fabricants de langages informatiques. Ils suppriment des fonctions sans se soucier des conséquences pour les logiciels en cours.
Par contre si une version convient parfaitement à tes besoins, il n'est pas forcément nécessaire de la changer

Citation
   Bonjour,
 PS: un stock en e-commerce avec un comptage du stock visible pour les acheteurs me fera acheter votre version e-commerce.
Plus qu'à espérer que ça sorte demain  Souriant
Pour cette demande, n'espère pas trop pour une prochaine mise à jour   Clin d'oeil
Cdlt
frangin62
« Dernière édition: 02 Avril 2019 à 16h09 par frangin62 » Journalisée

frangin62
Hero Member
*****

Nombre de "j'aime" : 96
Messages: 2014



WWW
« Répondre #9 le: 02 Avril 2019 à 16h36 »

Re:
Pour le fait que tu ne reçois pas tes mails, as-tu suivi cette procédure
http://frangin62.free.fr/ajoutmailing.html
Journalisée

prapilk
Newbie
*

Nombre de "j'aime" : 0
Messages: 9


« Répondre #10 le: 02 Avril 2019 à 21h05 »

Oui j'ai tout configuré.

J'essaye en attendant avec Sendblaster et les scripts proposé ici :
https://www.sendblaster.fr/aide/liste-base-sur-permissions/modules-inscription-mailing-list/

Mais je n'ai toujours aucun mail.

J'ai essayé directement en rajoutant le script dans toweb avec les fichiers joints par toweb, ou direct upload FTP rien n'y fait.

Ca commence à dépasser largement mes compétences Triste


Journalisée
frangin62
Hero Member
*****

Nombre de "j'aime" : 96
Messages: 2014



WWW
« Répondre #11 le: 02 Avril 2019 à 22h22 »

Ce que tu as téléchargé n'est que le formulaire d'inscription, hors avec TOWeb tu dis que ça fonctionne.
Si tu veux utiliser SendBlaster pour envoyer des mails, je pense qu'il te faut plutôt ceci
https://www.sendblaster.fr/telecharger-logiciel-emailing-gratuit/

Par contre, si le formulaire de contact fonctionne, donc la fonction mail() est ok chez l'hébergeur, l'inscription à la news fonctionne également et que tu as bien paramétré les options d'envoi, là je ne vois pas ce qui peut te bloquer.
Au fait, quel est ton fournisseur de messagerie ? (SFR, Orange, Free……)
Cdlt
frangin62
Journalisée

prapilk
Newbie
*

Nombre de "j'aime" : 0
Messages: 9


« Répondre #12 le: 03 Avril 2019 à 00h01 »

Bizarre, pour le moment tout fonctionne le mailing list et le formulaire....

Entre temps j'ai tenté l'install de table dans phpadmin que j'ai ensuite effacé.
Fais le test du mail() sur ATSPACE mon hébergeur.
Créer un compte FTP pour filezilla au lieu d'utiliser le générique de mon hébergeur.
Uploader à la racine un nouveaux répertoire.
Effacer ma rubrique pour refaire une nouvelle rubrique.

Je pige plus rien mais ça fonctionne avec l'ajout des contacts dans Toweb etc...

Sinon, je suis chez Scarlet en Belgique.

En continuant à tester, je me rends compte qu'il ne met pas les liens pour le désabonnement dans la mailing list.

En mailing list je ne recois pas les demande Gmail et certains autres professionnels.
Pour le moment je recois bien l'ensemble des formulaires.

Merci de ton aide frangin62, c'est vraiment bizarre cette situation.
Journalisée
lauyan
Support Lauyan
Full Member
*****

Nombre de "j'aime" : 11
Messages: 183



« Répondre #13 le: 18 Avril 2019 à 09h37 »

Bonjour,
ce problème devrait désormais être résolu avec la version 7.20 disponible depuis aujourd'hui.
https://www.lauyan.com/fr/toweb-updates.html

Cordialement,
Journalisée

L'équipe Support TOWeb
Lauyan Software
Pages: [1] Haut de page Imprimer 
« sujet précédent | | sujet suivant »
Aller à:  


TOWeb - Le logiciel de création de site Internet responsive Cliquez ici pour vous abonner au flux RSS du forum Règles du Forum  -   © 2005-2013 Lauyan Software
Powered by SMF 1.1.18 | SMF © 2006-2009, Simple Machines